Frame Relay Switch on a Cisco Router

Frame Relay Switch on a Cisco Router

For this lab were used 5 cisco routers with IOS version 15.

With the rules set the connections between the interfaces of the frame relay switch are done in order to establish a path (PVC – Permanent Virtual Circuit) .

hostname SW-Frame-Relay
!
frame-relay switching
!
interface Serial0/0
description Multipoint to R2 and R3
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 200 interface Serial0/2 100
frame-relay route 300 interface Serial0/3 100
no shutdown
!
interface Serial0/1
description Point-to-Point to R2
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 100 interface Serial0/2 101
no shutdown
!
interface Serial0/2
description Point-to-Point to R1 and Multipoint to R0 and R3
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 101 interface Serial0/1 100
frame-relay route 100 interface Serial0/0 200
frame-relay route 300 interface Serial0/3 200
no shutdown
!
interface Serial0/3
description Multipoint to R0 and R2
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 100 interface Serial0/0 300
frame-relay route 200 interface Serial0/2 300
no shutdown

Point-to-Point Interface Configuration

R1 is configured with a point-to-point connection through the physical link to R2, connection DLCI (Data Link Connection Identifier)  100 to DLCI 101.

hostname R1
!
interface Loopback0
 description Local Lan
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
 description Connection to R2 Point-to-Point DLCI 100
 ip address 10.0.0.1 255.255.255.252
 encapsulation frame-relay
 no shutdown
!
router eigrp 10
 network 10.0.0.1 0.0.0.0
 network 192.168.1.1 0.0.0.0
 passive-interface default
 no passive-interface Serial0/0

Notice that the only configuration needed is the encapsulation protocol. The rest will be configured “automagically”. The process goes like this:

  1. LMI (Local Management Interface) on the Frame Relay Switch was configured to cisco which, as you can guess, is the default LMI configuration in all Cisco routers. The other option to configure the LMI are ANSI and Q933.
  2. LMI will retrieve the DLCI configure on the Frame Relay Switch interface to the router.
  3. With the respective DLCI, the router will issue an Inverse Arp to dynamically map the remote ip address to the received DLCI.

R2 was configured with a point-to-point sub-interface to terminate the other end of the PVC.

hostname R2
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no shutdown
!
interface Serial0/0.101 point-to-point
 description Connection to R1 DLCI 101
 ip address 10.0.0.2 255.255.255.252
 frame-relay interface-dlci 101   
!
R2#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 14/16/18 m

Notice that a sub-interface was created as a point-to-point after the encapsulation frame-realy was configured in the physical interface and that the same interface was brought up with the no shutdown command. Since a sub-interface was used it is necessary to inform the router which DLCI is going to match the interface, considering that the Frame Relay Switch interface has multiple paths configured.

The sub-interface command frame-realy interface-dlci 101 does the job.

Multipoint Interface configuration

R2 Full Configuration (multipoint sub-interface)

hostname R2
!
interface Loopback0
 description Local Lan
 ip address 192.168.2.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no shutdown
!
interface Serial0/0.101 point-to-point
 description Connection to R1 DLCI 101
 ip address 10.0.0.2 255.255.255.252
 frame-relay interface-dlci 101 
!
interface Serial0/0.200 multipoint
 description Connection to R0 DLCI 100 and R3 DLCI 300
 ip address 10.0.0.10 255.255.255.248
 frame-relay map ip 10.0.0.9 100 broadcast
 frame-relay map ip 10.0.0.11 300 broadcast
!
router eigrp 10
 network 10.0.0.2 0.0.0.0
 network 10.0.0.10 0.0.0.0
 network 192.168.2.1 0.0.0.0
 passive-interface default
 no passive-interface Serial0/0.101
 no passive-interface Serial0/0.200

R3 Configuration (multipoint sub-interface)

hostname R3
!
interface Loopback0
 description Local Lan 
 ip address 192.168.3.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no shutdown
!
interface Serial0/0.300 multipoint
 description COnnection to R0 DCLI 100 and R2 DLCI 200
 ip address 10.0.0.11 255.255.255.248
 frame-relay map ip 10.0.0.9 100 broadcast
 frame-relay map ip 10.0.0.10 200 broadcast
! 
router eigrp 10
 network 10.0.0.11 0.0.0.0
 network 192.168.3.1 0.0.0.0
 passive-interface default
 no passive-interface Serial0/0.300

R0 Configuration (multipoint on a physical interface)

hostname R0
!
interface Loopback0
 description Local Lan
 ip address 192.168.0.1 255.255.255.0
!
interface Serial0/0
 description Connection to R2 DCLI 200 and R3 DLCI 300
 ip address 10.0.0.9 255.255.255.248
 encapsulation frame-relay
 frame-relay map ip 10.0.0.11 300 broadcast
 frame-relay map ip 10.0.0.10 200 broadcast
 no shutdown
!
router eigrp 10
 network 10.0.0.9 0.0.0.0
 network 192.168.0.1 0.0.0.0
 passive-interface default
 no passive-interface Serial0/0

R0#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 14/16/18 ms
R0#ping 10.0.0.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 14/16/18 ms

With multipoint frame relay configuration a new problem arises, the interface in the Frame Relay Switch now has multiple path through the FR network. Because of this the router interface configuration must statically match the remote ip address with the correspondent local DLCI.

As you performe the interface configuration along with the routing configurations you will see the routing adjacencies come up.

R0#show ip route
Gateway of last resort is not set
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D        10.0.0.0/30 [90/2681856] via 10.0.0.10, 00:09:46, Serial0/0
C        10.0.0.8/29 is directly connected, Serial0/0
L        10.0.0.9/32 is directly connected, Serial0/0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback0
L        192.168.0.1/32 is directly connected, Loopback0
D     192.168.1.0/24 [90/2809856] via 10.0.0.10, 00:09:46, Serial0/0
D     192.168.2.0/24 [90/2297856] via 10.0.0.10, 00:09:46, Serial0/0
D     192.168.3.0/24 [90/2297856] via 10.0.0.11, 00:08:02, Serial0/0


R0#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 34/34/35 ms
R0#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 17/17/18 ms
R0#ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 17/17/18 ms

Frame Relay Verification

R0#show frame-relay map 
Serial0/0 (up): ip 10.0.0.10 dlci 200(0xC8,0x3080), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 10.0.0.11 dlci 300(0x12C,0x48C0), static,
              broadcast,
              CISCO, status defined, active
R1#sh frame-relay map
Serial0/0 (up): ip 10.0.0.2 dlci 100(0x64,0x1840), dynamic,
              broadcast,
              CISCO, status defined, active
R2#sh frame-relay map 
Serial0/0.200 (up): ip 10.0.0.9 dlci 100(0x64,0x1840), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.101 (up): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
          status defined, active
Serial0/0.200 (up): ip 10.0.0.11 dlci 300(0x12C,0x48C0), static,
              broadcast,
              CISCO, status defined, active
R3#show frame-relay map 
Serial0/0.300 (up): ip 10.0.0.9 dlci 100(0x64,0x1840), static,
              broadcast,
              CISCO, status defined, active
Serial0/0.300 (up): ip 10.0.0.10 dlci 200(0xC8,0x3080), static,
              broadcast,
              CISCO, status defined, active
SW-Frame-Relay#show frame-relay route 
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0/0       200             Serial0/2       100             active
Serial0/0       300             Serial0/3       100             active
Serial0/1       100             Serial0/2       101             active
Serial0/2       100             Serial0/0       200             active
Serial0/2       101             Serial0/1       100             active
Serial0/2       300             Serial0/3       200             active
Serial0/3       100             Serial0/0       300             active
Serial0/3       200             Serial0/2       300             active

See U on the next post.

Stay good.

Files:

framerelayswitchciscorotuer-zip

Remote the docx extension to upload directly to UnetLab.

Advertisements