Frame-Relay Cloud Configuration in Packet Tracer 7.0

Frame-Relay Cloud Configuration in Packet Tracer 7.0

I know that frame-relay is seeing his last days, but since some students asked for it here is as sample configuration of the generic cloud-pt as a frame-relay switch.

1º Step – Add a Generic Cloud to the Packet Tracer Topology

framerealypt2

2º Step – Add 3 router C2911

framerealypt3

3º Step – Add HWIC-2T modules to the routers to provide the serial interfaces needed for the frame-relay connections

framerealypt4

4º Step – Connect the serial interface 0/0/0 from each router to the cloud using a DTE Serial Cable. (it is important to connect from the router to the cloud and not the other way around)

framerealypt5

5º Step – Address used in the example:

  • IP Addresses
    • R1-R2 – 10.0.0.0/30
    • R1-R3 – 10.0.0.4/30
  • Data Link Connection Identifier (DLCI)
    • R1-R2 – 102
    • R1-R3 – 103
    • R2-R1 – 201
    • R3-R1 – 301

framerealypt6.gif

6º Step – Configure the Frame-Relay Cloud with the DLCI per Interface

framerealypt7

7º Step – Configure the Frame-Relay routes between the interfaces

framerealypt8

8º Step – We will had interface loopback in the configuration to simulate the local lans

framerealypt9.gif

9º Step – Configurations

! R1 Configuration
hostname R1
!
interface Loopback0
 description R1 Local Lan
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 no shutdown
!
!R1 has 2 DCLIs so we need to configure the subinterface
interface Serial0/0/0.102 point-to-point
 description Frame-Relay Connection to R2
 ip address 10.0.0.1 255.255.255.252
 ! we need to indicate the DLCI for each subinterface
 frame-relay interface-dlci 102
!
interface Serial0/0/0.103 point-to-point
 description Frame Relay Connection to R3
 ip address 10.0.0.5 255.255.255.252
 frame-relay interface-dlci 103
!
router eigrp 10
 passive-interface default
 no passive-interface Serial0/0/0.102
 no passive-interface Serial0/0/0.103
 network 192.168.1.1 0.0.0.0
 network 10.0.0.1 0.0.0.0
 network 10.0.0.5 0.0.0.0
! R2 Configuration
hostname R2
!
interface Loopback0
 description R2 Local Lan
 ip address 192.168.2.1 255.255.255.0
!
! One DLCI with the physical interface 
! With the Local Management Interface (LMI) and Inverse-ARP
! The mapping is automatic
interface Serial0/0/0
 description Frame Relay Connection to R1
 ip address 10.0.0.2 255.255.255.252
 encapsulation frame-relay
 no shutdown
!
router eigrp 10
 passive-interface default
 no passive-interface Serial0/0/0
 network 192.168.2.1 0.0.0.0
 network 10.0.0.2 0.0.0.0
! R3 Configuration
hostname R3
!
interface Loopback0
 description R3 Local Lan
 ip address 192.168.3.1 255.255.255.0
!
! One DLCI with the physical interface 
! With the Local Management Interface (LMI) and Inverse-ARP
! The mapping is automatic
interface Serial0/0/0
 description Frame Relay Connection to R1
 ip address 10.0.0.6 255.255.255.252
 encapsulation frame-relay
 no shutdown
!
router eigrp 10
 passive-interface default
 no passive-interface Serial0/0/0
 network 192.168.3.1 0.0.0.0
 network 10.0.0.6 0.0.0.0

10º Step – Verification and Test

R3# show ip route

  10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.0.0.0/30 [90/2681856] via 10.0.0.5, 00:00:07, Serial0/0/0
C 10.0.0.4/30 is directly connected, Serial0/0/0
L 10.0.0.6/32 is directly connected, Serial0/0/0
D 192.168.1.0/24 [90/2297856] via 10.0.0.5, 00:00:07, Serial0/0/0
D 192.168.2.0/24 [90/2809856] via 10.0.0.5, 00:00:07, Serial0/0/0
  192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.3.0/24 is directly connected, Loopback0
L 192.168.3.1/32 is directly connected, Loopback0
R3#
R3# show frame-relay map
Serial0/0/0 (up): ip 10.0.0.5 dlci 301, dynamic,
broadcast,CISCO, status defined, active
R3#
R3# ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/15/31 ms

R3# ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/14/28 ms
R3#

Video

Until next post, stay good.

Advertisements